Odeslat nové téma Odpovědět na téma  [ Příspěvků: 2 ] 
Autor Zpráva
PříspěvekNapsal: čtv 30.06.2016 8:09 
Mazák
Mazák
Uživatelský avatar

Registrován: 8.10.2012
Příspěvky: 1480
Bydliště: Kladno
Zdravím,

myslíte, muže být HW vadný seriový telemetrický port na atmega2560 v mini APM.

popis stavu.

1 připojeno 433 telemetrie - vše OK
2 připojeno paralerně OSD, pouze AMP TX -> OSD RX - vše OK
3 po 433 spojeno s MP - vše OK
4 nespojeno s MP data s OSD zmizí - komunikace po 433 je OK
následující den bez jakého koli zásahu
5 nyní už se nespojím s MP pře 433 (komunikace na SR1 nefunguje, radio 433 je OK) ani na přímo přes FTDI na portu SR1 (SR0 - spojení OK)
6 data OSD nejsou

bod 5 6 by mohl dávát smysl - vadný port

ale

začnu se spojovat s MP takže je vyvolána snaha o komunikaci a po dobu vypršení timeoutu jsou data na OSD .

čemu nerozumím, v podstatě, když něco leze na RX APM SR1 tak z TX téhož portu lezou data na OSD, z toho by plynulo že CPU reaguje na vnější signály, muže být port nějak částečné nakopnut ?

upgrade FW i různé změny Copter/Letadlo , reset defaul, nic z toho nepomohlo.

dotaz 2
funguje Vám OSD pouze s jedním drátem APM TX - OSD RX, když není navázaná komunikace s MP na tom samém portu. (433 telemetrie)

verze OSD minim EXTRA 2.4 R800


Nahoru
 Profil  
 
 
PříspěvekNapsal: čtv 30.06.2016 12:21 
Zkušený debatér
Zkušený debatér
Uživatelský avatar

Registrován: 24.7.2011
Příspěvky: 262
Bydliště: Ostrava - Poruba
Kouknout na datové vodiče osciloskopem...


Nahoru
 Profil  
 
Zobrazit příspěvky za předchozí:  Seřadit podle  
Odeslat nové téma Odpovědět na téma  [ Příspěvků: 2 ] 

 


Kdo je online

Uživatelé procházející toto fórum: Žádní registrovaní uživatelé a 2 návštevníků


Nemůžete zakládat nová témata v tomto fóru
Nemůžete odpovídat v tomto fóru
Nemůžete upravovat své příspěvky v tomto fóru
Nemůžete mazat své příspěvky v tomto fóru
Nemůžete přikládat soubory v tomto fóru

Hledat:
Přejít na:  

 

  Powered by phpBB® Forum Software © phpBB Group  Český překlad – phpBB.cz 

 

NAVRCHOLU.cz